php - Symfony Deployment Path /public/-文件夹问题

我目前正在将我的第一个 Symfony-项目上线。除了正确的路由外,一切正常。所以我可以看到我的网站的链接“www.mywebsite.de/mywebsite/public/” 在我创建 htaccess 文件之前,链接是“www.mywebsite.de/mywebsite/public/index.php "

当我想到达登录端时,它会将我定向到 path "www.mywebsite.de/login/ 但是由于错误的 path 出现错误 404 ... path "www.mywebsite .de/mywebsite/public/login" 会起作用。

所以我的目标是每个方面都可以使用地址“www.mywebsite.de/...”我从我的研究中知道(是的,我已经阅读了 https://symfony.com/doc/current/setup/web_server_configuration.html)我应该将 htaccess 规则移动到主 Apache 配置文件。我也应该在那里做一些改变。

我的问题:我的网络提供商不允许访问 Apache 配置文件。所以我没有办法做出这些改变。还有其他方法可以纠正 paths 吗?

这是我在 de publicFolder 中的 .htaccess

# Use the front controller as index file. It serves as a fallback solution when
# every other rewrite/redirect fails (e.g. in an aliased environment without
# mod_rewrite). Additionally, this reduces the matching process for the
# start page (path "/") because otherwise Apache will apply the rewriting rules
# to each configured DirectoryIndex file (e.g. index.php, index.html, index.pl).
DirectoryIndex index.php

# By default, Apache does not evaluate symbolic links if you did not enable this
# feature in your server configuration. Uncomment the following line if you
# install assets as symlinks or if you experience problems related to symlinks
# when compiling LESS/Sass/CoffeScript assets.
# Options FollowSymlinks

# Disabling MultiViews prevents unwanted negotiation, e.g. "/index" should not resolve
# to the front controller "/index.php" but be rewritten to "/index.php/index".
<IfModule mod_negotiation.c>
    Options -MultiViews
</IfModule>

<IfModule mod_rewrite.c>
    RewriteEngine On

    # Determine the RewriteBase automatically and set it as environment variable.
    # If you are using Apache aliases to do mass virtual hosting or installed the
    # project in a subdirectory, the base path will be prepended to allow proper
    # resolution of the index.php file and to redirect to the correct URI. It will
    # work in environments without path prefix as well, providing a safe, one-size
    # fits all solution. But as you do not need it in this case, you can comment
    # the following 2 lines to eliminate the overhead.
    RewriteCond %{REQUEST_URI}::$0 ^(/.+)/(.*)::\2$
    RewriteRule .* - [E=BASE:%1]

    # Sets the HTTP_AUTHORIZATION header removed by Apache
    RewriteCond %{HTTP:Authorization} .+
    RewriteRule ^ - [E=HTTP_AUTHORIZATION:%0]

    # Redirect to URI without front controller to prevent duplicate content
    # (with and without `/index.php`). Only do this redirect on the initial
    # rewrite by Apache and not on subsequent cycles. Otherwise we would get an
    # endless redirect loop (request -> rewrite to front controller ->
    # redirect -> request -> ...).
    # So in case you get a "too many redirects" error or you always get redirected
    # to the start page because your Apache does not expose the REDIRECT_STATUS
    # environment variable, you have 2 choices:
    # - disable this feature by commenting the following 2 lines or
    # - use Apache >= 2.3.9 and replace all L flags by END flags and remove the
    #   following RewriteCond (best solution)
    RewriteCond %{ENV:REDIRECT_STATUS} =""
    RewriteRule ^index\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]

    # If the requested filename exists, simply serve it.
    # We only want to let Apache serve files and not directories.
    # Rewrite all other queries to the front controller.
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ %{ENV:BASE}/index.php [L]
</IfModule>

<IfModule !mod_rewrite.c>
    <IfModule mod_alias.c>
        # When mod_rewrite is not available, we instruct a temporary redirect of
        # the start page to the front controller explicitly so that the website
        # and the generated links can still be used.
        RedirectMatch 307 ^/$ /index.php/
        # RedirectTemp cannot be used instead
    </IfModule>
</IfModule>

回答1

这是因为您的 Apache Web 服务器的应用程序入口点设置为 /mywebsite 而不是标准 .htaccess 文件要求的 /mywebsite/public。由于您无权访问您的网络服务器设置,只需将您的 .htaccess 文件从 /mywebsite/public 移动到站点的根目录 /mywebsite 并将内容替换为:

DirectoryIndex public/index.php
<IfModule mod_negotiation.c>
    Options -MultiViews
</IfModule>
<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_URI}::$0 ^(/.+)/(.*)::\2$
    RewriteRule .* - [E=BASE:%1]
    RewriteCond %{HTTP:Authorization} .+
    RewriteRule ^ - [E=HTTP_AUTHORIZATION:%0]
    RewriteCond %{ENV:REDIRECT_STATUS} =""
    RewriteRule ^index\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ %{ENV:BASE}/public/index.php [L]
</IfModule>
<IfModule !mod_rewrite.c>
    <IfModule mod_alias.c>
        RedirectMatch 307 ^/$ /public/index.php/
    </IfModule>
</IfModule>

您还需要更改 Asset 组件的 base_path 参数(如果使用),以便正确加载资源

添加到 config/packages/framework.yaml 文件新基础 path:

framework:
    assets:
        base_path: /public

相似文章

composer-php - Composer 安装后脚本未执行

我正在尝试构建一个包含PHP应用程序的docker映像。此应用程序通过composer.json安装一些依赖项,并且在composer安装后,需要完成一些自定义(例如,必须将某些文件从供应商文件夹复制...

最新文章