javascript - 将使用 npx 创建的 React v17 降级到 v18

如何降级使用“npx create-react-app .--template typescript”创建的项目。我在网上找到的所有帖子都建议手动更改依赖项然后运行“npm install”,但是当我这样做时总是会出现一些错误。如何修改依赖项以使其与 react v17 一起使用?

这是我降级的尝试:

"dependencies": {
"@testing-library/jest-dom": "^5.16.4",
"@testing-library/react": "^13.2.0",
"@testing-library/user-event": "^13.5.0",
"@types/jest": "^27.5.1",
"@types/node": "^16.11.36",
"@types/react": "^17.0.2",
"@types/react-dom": "^17.0.2",
"react": "^17.0.2",
"react-dom": "^17.0.2",
"react-scripts": "5.0.1",
"typescript": "^4.6.4",
"web-vitals": "^2.1.4"

}

这是错误:

npm WARN ERESOLVE 覆盖对等依赖

npm WARN 解析时:hard-keys-react17@0.1.0

npm 发现警告:react@18.1.0

npm 警告 node_modules/react

npm WARN react@"^17.0.2" 来自根项目

npm 警告 3 个以上 (@testing-library/react, react-dom, react-scripts)

npm 警告

npm WARN 无法解析依赖:

npm 警告对等体 react@"^18.0.0" 来自@testing-library/react@13.2.0

npm 警告 node_modules/@testing-library/react

npm WARN @testing-library/react@"^13.2.0" 来自根项目

npm WARN ERESOLVE 覆盖对等依赖

npm WARN 解析时:hard-keys-react17@0.1.0

npm 发现警告:react@18.1.0

npm 警告 node_modules/react

npm WARN react@"^17.0.2" 来自根项目

npm 警告 3 个以上 (@testing-library/react, react-dom, react-scripts)

npm 警告

npm WARN 无法解析依赖:

npm 警告对等体 react@"^18.1.0" 来自 react-dom@18.1.0

npm 警告 node_modules/react-dom

npm WARN react-dom@"^17.0.2" 来自根项目

npm 警告 1 个 (@testing-library/react)

npm WARN ERESOLVE 覆盖对等依赖

npm WARN 解析时:hard-keys-react17@0.1.0

npm 发现警告:react-dom@18.1.0

npm 警告 node_modules/react-dom

npm WARN react-dom@"^17.0.2" 来自根项目

npm 警告 1 个 (@testing-library/react)

npm 警告

npm WARN 无法解析依赖:

npm 警告对等体 react-dom@"^18.0.0" 来自 @testing-library/react@13.2.0

npm 警告 node_modules/@testing-library/react

npm WARN @testing-library/react@"^13.2.0" 来自根项目

回答1

你总是可以跑

npm resolve dependencies

手动降级可能会发出一些警告,告诉您有比您现在使用的版本更新的版本,但它仍然可以正常工作。

你在你的 package.json 中犯了一个错误

"react-scripts": "5.0.1",

做了

"react-scripts": "^5.0.1",

相似文章

math - 数字之间的和与差

是否可以找到两个数字a和b使得a和b之间的差等于a和b中的数字之和?是否可以为此编写一个通用方程?...

最新文章