android - Android - 无法解析 org.jetbrains.kotlin:kotlin-gradle-plugin:1.6.10

我最近升级到 Flutter 3.0。后来我在尝试运行后遇到了一个问题。下载完 Gradle 6.7 并启动 Gradle 守护程序后,出现此错误

无法解析配置“:classpath”的所有 artifacts。无法解析 org.jetbrains.kotlin:kotlin-gradle-plugin:1.6.10。要求:项目:> 无法解析 org.jetbrains.kotlin:kotlin-gradle-plugin:1.6.10。 > 无法获取资源 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-gradle-plugin/1.6.10/kotlin-gradle-plugin- 1.6.10.pom'。 > 无法获取 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-gradle-plugin/1.6.10/kotlin-gradle-plugin-1.6 .10.pom'。 > 连接到 jcenter.bintray.com:443 [jcenter.bintray.com/34.95.74.180] 失败:连接超时

作为 Flutter 处理错误的方式,我陷入了循环,因为我不知道的原因不断地重新下载 gradle zip 文件,并无休止地导致同样的错误。

回答1

在通过注释掉 jcenter() 并在 android/build.gradlerepositories 括号中将其替换为 mavenCentral() 之后,按照@curioshikhov 的回答,错误消失了。

原来错误是由连接超时引起的。我责怪服务器,因为我的连接很好。之后会出现更多类似的错误。我必须反复运行 gradlew clean 才能完全通过这一切。

(对于 Flutter 用户)。 Flutter 的 app build 也出现了类似的错误。 Flutter 的问题是一旦发生,它只是简单地删除、重新下载并从开始重复运行 gradle,导致它重新下载所有内容以解决依赖关系。

相似文章

最新文章